Rutinas básicas en Blender para modelado arquitectónico

RUTINAS BÁSICAS Y COMANDOS PARA MANEJO DE BLENDER EN MODELADO ARQUITECTÓNICO

A continuación se detallan una serie de comandos y rutinas básicas que permitan facilitar a arquitectos el trabajar con Blender. Esto pues muchas de las rutinas que los arquitectos usan en softwares tipo CAD son distintas en Blender.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

DIBUJO DE CURVAS

Acá una rutina básica sobre las curvas. Que en realidad es de circulos.

1.- Tecla numpad 7 para ver la ventana 3D en planta.

2.- ubica el cursor 3D sobre la grilla o sobre un punto seleccionado para recibir el centro del circulo: Shift + S

3.- Agrega un circulo: menú Add> mesh> circle.

4.- en Edit Mode veras que el circulo que aparece esta compuesto de un sin numero de tramos rectos. Puedes escalar el circulo (tecla E) hasta algún punto de referencia usando el snap habilitado. Ese punto de referencia lo puedes crear duplicando cualquier elemento existente (punto o línea) y desplazándolo (Shift + D, fijando coordenada con Y o X).

5.- Borra los vértices del circulo que están de mas, de forma que dejas solo el tramo de curva que te interesa.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

DIBUJO DE MIRRORS

Nota para un dibujo simetrico lo mas conveniente es dibujar un segmento del elemento y luego hacer mirrors:

A) Seleccionar elemento

B) Shift+D

C)tecla S y luego tecla X

D) tipear -1

E) Enter.

Finalmente se ubica el duplicado seleccionándolo y moviéndolo con la tecla G

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

USO DEL CURSOR 3D COMO PIVOTE PARA ROTAR Y ESCALAR

1.- Los objetos tienden a pivotear de distinta manera, dependiendo del centro de pivote (esto para rotar y escalar).

2.- El centro del pivote puede ser el origen (el puntito naranja de los objetos), el centro geométrico de un conjunto de elementos, etc. y también el cursor 3D.

3.- El cursor 3D es lo mas útil para este tipo de operaciones de transformar (rotar, escalar).

4.- para usar el cursor 3D como pivote ve al icono que esta en la parte de abajo de la pantalla llamado punto pivote (en la misma línea de los menús View Select Mesh Mode  Shading). Y selecciona "pivote en cursor 3D". Ahora, los objetos rotaran y escalaran referenciados a la ubicación del cursor 3D.

5.- para ubicar el cursor 3D con exactitud en algún lugar presiona las teclas shift + S. Aparecerá un menú de opciones de SNAP para el cursor. Asi, si quieres que el cursor 3D quede ubicado en una arista del objeto ve a: "edit mode" > edge select mode > selecciona la arista del plano con el botón derecho del mouse > presiona shift+s > en el menú escoge "cursor a selección". Ahora el cursor 3D esta ubicado en la arista escogida.  la misma operación si quieres que sea un vértice es "vertex select mode" y haces click sobre el vértice en cuestión. "Select mode" son el icono de los tres cubitos que se ve en el menú de abajo de la pantalla con "edit mode" como estado.

6. Ahora puedes rotar presionando la tecla R o el icono de la línea curva azul que hace que aparezcan los vectores de colores en la pantalla para manipularlos con el mouse. Como esta configurado para pivotear en el cursor el objeto pivoteara en la arista (object mode). Si estas en "edit mode" debes marcar "face select mode" y seleccionar la cara que quieres pivotear.

Notas: con respecto al origen (puntito naranja) este solo puede manipularse de tres modos: presionado el botón origen en menú izquierdo ( tecla T, en object mode) y ordenando que se mueva hacia la geometría, la geometría hacia el, o el origen hacia el cursos 3D. Por eso es mas practico usar el cursor 3D para labores de transformación. Tiene otros usos que lo hacen una herramienta muy util.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

COMO DIBUJAR LINEAS (ESTILO POLILINEA) EN BLENDER

1.- Primero debemos estar con la ventana 3D mirando en planta: tecla 7 del numpad (con el tecla 5 cambiamos entre perspectiva y ortogonal)

2.- El cursor 3D debe estar en la grilla (los elementos aparecen en la escena donde esta el cursor 3D) Si no lo esta: Shift + s > cursor to center / cursor to grid

3.- Insertamos una curva bezier en la escena: Menu Add > Curve > Bezier

4.- Veremos la curva bezier de color anaranjado (pues debe estar seleccionada, además estamos en ambiente object mode). Ahora vamos a convertirla en una malla o mesh.

5.- Menu Object> Convert to> Mesh form Curve

6.- Cambia a modo Edit mode y veras que la curva ahora esta compuesta de como 12 tramos de rectas con sus vértices (creo que se puede reducir el numero de rectas pero no se como. Yo me acuerdo que convertía estos como a 4 o 5 tramos, pero no me acuerdo como). Ahora con el botón derecho del mouse puedes seleccionar cada vértice y moverlo. recuerda que debes tener marcada la opción vertex select mode y siempre mirando en planta el dibujo pues de otro modo cuando desplaces un elemento este se moverá en un espacio tridimensional.

7.- Selecciona el ultimo vértice de un extremo de la línea y a continuación presiona la tecla E. Esto es el comando extrusión con lo que estas creando una línea desde el vértice seleccionado. De hecho puedes seleccionar cualquier vértice y te creara una línea arrancando desde allí. Con un click del botón izquierdo del mouse fijas el nuevo punto. Repite: tecla E + click con el mouse y estarás dibujando una polilinea.

7.a.- Otra mesh posible de insertar y manipular es un simple plano. Basta con seleccionar y borrar tres de sus vertices para disponer de un punto-vertice que extruir.

8.- Activa el comando Snap (magneto) para coincidir con los otros vértices (o lados o caras) y podrás dibujar con precision.

9.- Seleccionando vértices o lados que están de mas puedes borrarlos con la tecla Delete. Presiona tecla B y click con el mouse arrastrando > tecla Delete> borrar vertex, faces, edges, etc.

Cualquier error puedes volver atrás con el comando tecla control + z

Para dibujar solo en vertical u horizontal al momento de desplazar el mouse fija la coordenada presionando la tecla X o Y.

PD: Y por supuesto que si estas partiendo desde un dibujo Cad  2D importado a blender, no necesitas trabajar con la curva blezier. Solo has extrude desde cualquier vértice del dibujo... ;)

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

COMANDO DE SELECCION MULTIPLE

1.- Tecla B > seleccion con boton derecho del mouse y arrastrar.

 Nota: Para modificar las preferencias de este comando: File> User preferences> Input> 3D view >3D view (global) > border select

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

MIRROR MODIFIER

Un Mirror Modifier es un comando que permite modelar un cuerpo simétrico solo trabajando la mitad. Es útil cuando se trabaja con formas simétricas que suelen ser comunes en arquitectura.
1.- Inserta un plano y ejecuta extrusiones en sus lados de forma de crear una figura plana (Edit mode).
2.- Antes de trabajar con el mirror debemos ubicar el origen en el eje de simetría de nuestra figura (el origen es el punto naranja):
a) Primero ubica el cursor 3D en el eje de simetria de la figura (Shift+S).
b) Luego ve a menú> Object>Transform>origen a cursor 3D. Así el origen queda ubicado en el eje donde esta el cursor.
3.- Para activar el Mirror Modifier ve al panel de herramientas de la derecha (bajo la lista de elementos y haz click sobre el icono "Modifiers" y de la lista en el botón escoge  Add Modifiers> Mirror. Ahora veras que la figura tiene un reflejo que parte desde el eje donde esta el origen del objeto.
4.- A medida que vas editando un lado de la figura los cambios se producen automáticamente en el otro lado. En la caja de herramientas de Mirror Modifier puedes marcar la casilla Clipping. Si haces eso las extrusiones no se extienden mas allá del eje de simetría, evitando superponer mallas. Si en la misma caja haces click sobre la X superior el mirror se desactiva y desaparece también el volumen reflejado.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Comentarios

Warcos

exelente

son fundamentales ... muchas veces uno tiene tiempo trabajando con una herramienta y hay detalles que deja pasar por alto....

tambien existe una forma de selecionar los Objetos sin apretar B.. que es lo que queria hace un tiempo y se puede haces asi:

en la ventana 3Dview, en la parte izquierda-abajo activamos la opcion: User Preferences---> Inpud
primero cambiamos donde dice Select With ..rigth por left

lugo bamos a:

----> 3D view -----> 3D view (global) ----> Border Select

en la opcion Border Select ... cambiamos Keyboard.. por.. Tweak

y prueben la configuracion nueva de blender.. je je jeee..

Toni

Muy interesante me lo apunto

Muy interesante me lo apunto y probaré algo estos días.

bitacovir

La idea es que se puede ir

La idea es que se puede ir compartiendo algunos tips entre nosotros. Ahora mismo agrego el Mirror Modifier.