Breve guía para modelar arquitectura en Blender 2.55

Breve guía para modelar arquitectura en Blender 2.55

Nota: ver informacion complementaria al final de esta guía.

INDICE

Capítulo 0
Presentación

Capítulo 1
Conociendo el nuevo Blender

Capítulo 2
Modelado arquitectónico con Blender

 

PRESENTACION

Es sabido que Blender es una poderosa herramienta para modelado 3D digital, pero que tiene un modo de funcionamiento y una interfaz que son distintas a las de otros programas 3D, que los arquitectos suelen utilizar.
Además, no se puede desconocer que Blender es un programa pensado para otros usos, más allá que el de simple modelado típico de programas de diseño o ingeniería. De hecho, reúne también amplias funciones para animación, composición, video y juegos. Esto hace que para muchos les resulte difícil atreverse a trabajar con esta potente herramienta, al sentirla no muy intuitiva y poco focalizada.
Sin embargo, Blender 3D tiene otras características que son ventajas. La principal es que se trata de Software Libre y además gratuito, por lo que puedes descargarlo e instalarlo sin ninguna restricción y sin costo. Otra ventaja es que está disponible en todas las plataformas, por lo que puedes instalarlo en Windows, Mac OSX o GNU-Linux.

Como una forma de dar un pequeño apoyo a los arquitectos que estén interesados en trabajar con Blender, a pesar de que éste no disponga de las típicas herramientas tipo CAD a las que estamos acostumbrados, he preparado esta pequeña guía de como trabajar con comandos básicos para modelar objetos, de manera de lograr resultados similares a los que obtienen los arquitectos al trabajar con programas como 3DMax o SketchUp.
Debo advertir, eso si, que yo no soy un experto en Blender. Recién lo estoy conociendo, así que no manejo todas las respuestas, ni mis métodos serán los mejores. Las instrucciones recopiladas aquí, las he ido recolectando de diferentes manuales de la red y estoy seguro nos ayudarán a formar una base lo suficientemente sólida, para que todos los que estamos interesados en aprender a utilizar esta estupenda herramienta, podamos sacarle el mejor provecho.

P.D: Antes de comenzar, descarga e instala la última versión de desarrollo de Blender (v2.55) de la página web de la
Fundación Blender: http://www.blender.org/

 

CONOCIENDO AL NUEVO BLENDER

Interfaz Gráfica de Usuario

Partiremos explicando brevemente como es la nueva interfaz gráfica de Blender 2.55b, ya que esta ha variado de las versiones anteriores, lo que ayudará a muchos posibles interesados, pues la vuelve un poco más cercana a lo que la gente suele ver en otros softwares similares.
La interfaz de Blender 2.55 se compone de una serie de "ventanas" las que son configurables según el trabajo que se esté realizando, pero que por defecto se presentan así:

Puedes ver la imagen más agrande aquí: http://www.tuimg.com/images/screenupu.png

  1. Ventana superior de Menú general. Configuración del programa, parámetros del archivo y creación de objetos.
  2. Ventanas de herramientas. Permite algunas ediciones al objeto. Se activa con la tecla T.
  3. Ventana parámetros. Permite ajustar parámetros del objeto. Se activa con la tecla N.
  4. Ventana 3D. Vista de la escena. Se controla el zoom, rotación y desplazamiento de la vista con el mouse y también con el NumPad:
    1. -Tecla 1 , vista lateral.
    2. -Tecla 3, vista frontal.
    3. -Tecla 7, vista en planta.
    4. -Teclas 2, 4, 6, 8, vista en rotación.
    5. -Tecla 5, cambia entre vista ortogonal y perspectiva.
    6. -Tecla 0, vista desde la cámara.
    7. -Tecla +, -, zoom a la vista.
    8. -Scroll del mouse (rueda), zoom.
    9. -Botón derecho del mouse, rotación de la vista.
    10. -Shift + boton central del mouse (scroll), pan o desplazamiento de la vista.
    11. -Botón izquierdo del mouse, reubica cursor 3D.
  5. Ventana de listado raíz de elementos (existentes en la escena).
  6. Ventana de botonera. Configura parámetros de la escena.
  7. Ventana Menú de parámetros y modificación de objetos.
  8. Ventana linea de tiempo para animación.

 

Interactuando con la escena 3D

Vamos a referirnos ahora a la Ventana 3D y los elementos que aparecen en ella, así como interactuar con ellos, ya que suele confundir bastante a los usuarios noveles.
Por defecto al iniciar el programa veremos en la ventana una escena con tres elementos: un cubo, una cámara y una lámpara (también podemos ver una grilla de referencia). Supongo que no es necesario explicar la función de la cámara y la lámpara, pero si no lo sabes, se utilizan para cuando se realizan renders del objeto. El cubo es una malla (Mesh) por defecto del programa al iniciarse. Es posible configurar el programa para que inserte otro objeto como un cono, una esfera o ninguna. Desde el menú Add de la ventana superior se pueden agregar otros objetos a la escena.

Podemos ver en la imagen anterior que el cubo aparece resaltado con un contorno naranja. Eso indica que dicho elemento está seleccionado. Para seleccionar otro elemento como la cámara o la lámpara debemos hacer click con el botón derecho del mouse, apuntando con el cursor sobre el nuevo elemento.
Lo otro a destacar es que la escena está en “Object Mode” (Modo Objeto, indicada con una flecha roja en la imagen). Bajo este modo es que se puede seleccionar entre diferentes objetos de una escena.

Para cada objeto se observan una serie de componentes:

Cursor 3D: Indica la posición donde aparecerán los objetos que se agregan a la escena. Se reubica haciendo click con el botón izquierdo del mouse.
Objeto 3D: Elemento 3D presente en la escena (denominados mallas o mesh).
Origen: Es el punto naranja. Es como el centro de gravedad o centro de masa del objeto o conjunto. Puede ser desplazado (para retornarlo al centro geométrico del objeto: menú Object > Transform > Origen to Geometry).

 

Estos son la mayoría de los comandos que usaremos principalmente para interactuar con los modelos. Los iré
explicando más adelante:

1 .- Menús
2.- Selección Modo Objeto/
3.- ViewPort Shading (muestra los objetos como solidos, semi transparentes, modelo de alambre, etc)
4.- Punto de pivote.
5.- Transformador 3D
6.- Layers
7.- Snap (magneto. Sí, el mismo de la mayoría de los programas CAD)
8.- Renderiza una imagen y video de la visión de la ventana 3D.

 

En Modo Edición (Edit Mode) aparecen y desaparecen otros menús:

1 .- Selección Modo Edición
2.- Modo selección Vertex/Edge/Plane

 

Transformar.

En modo Object Mode también se pueden realizar modificaciones básicas como trasladar el objeto, copiar, rotar,
escalar, etc. Para esto usaremos los íconos Transformador 3D (flecha, curva, recta) que se ven en la parte baja de la
pantalla.

Verás que cada objeto se presenta con tres vectores o coordenadas de colores, si los arrastras con el mouse verás
como se transforma el objeto, en forma fija a cada coordenada (si pinchas en el circulo blanco en el origen de los
vectores, se logra una transformación libre).

   

También se puede transformar el objeto con los botones de la columna de la izquierda (ventana tools/tecla N) o desde
el menú: Object > Transform > Grab (ATAJOS: tecla G, tecla R, tecla S). El comando se cancela con tecla Esc o
botón derecho del mouse.

Las transformaciones pueden ser libres o fijas a alguna de las coordenadas del espacio 3D de Blender. Estas
coordenadas están definidas como X, Y, y Z y los atajos en el teclado son las teclas con esas letras.
Si deseamos borrar el objeto seleccionado, presionamos la tecla Supr (o la tecla X) y confirmamos con la tecla Enter.

TIP: Al presionar las teclas que representan las coordenadas Z, X , Y se restringen las transformaciones al respectivo sentido de la coordenada elegida.

TIP: Para deshacer una acción presiona las teclas Ctrl + Z

Editar

Para editar un objeto se debe tener seleccionado el objeto en cuestión y a continuación cambiar en el menú a Modo
Edición (Edit Mode), tal como se observa en la siguiente imagen, al lado izquierdo marcado con una flecha.
En este modo, el objeto cambia y se torna completamente naranja (puedes des-seleccionar con la tecla A). Además
aparecen nuevas herramientas y menús. Las propiedades del objeto que pueden ser identificadas son principalmente
vértices, aristas y caras. Dichas opciones podemos seleccionarlas entre los íconos respectivos, señalizados con otra
flecha a la derecha en la imagen (y que son visibles sólo en este modo de edición). Estos tres íconos se denominan
"modo selección vértice/arista/cara".

Establecer como Edit Mode y marcar selección de Vértices:

 

Así, si deseamos editar un objeto, por ejemplo desplazando o estirándole un vértice, primero seleccionamos el objeto
en Object Mode, luego pasamos a Edit Mode y elegimos vista de Vértices y a continuación marcamos el ícono Move
(flecha) en el Transformador 3D. Todo el proceso lo he señalizado con tres marcas en la siguiente imagen. El vértice
específico que queremos mover (arista o cara) lo seleccionamos con el botón derecho del mouse (lo que lo deja de
color naranja) y finalmente arrastramos una de las respectivas 3 coordenada (o el circulo blanco en el origen de los
vectores, para un movimiento libre):

 

TIP: Tecla TAB permite pasar de Object Mode a Edit Mode rápidamente.

El ejercicio se repite si lo que queremos es rotar una arista o escalar una cara, como muestra la imagen siguiente:

Nota: No se pueden seleccionar vértices, aristas o caras de mallas independientes en Modo Edición (Edit Mode). Este
modo sólo actúa en una malla a la vez. Los objetos independientes se seleccionan previamente en Modo Objeto
(Object Mode). Claro que una misma malla puede estar compuesta de varias figuras (conos, esferas, etc).

Muchos de los atajos para edición son similares a los de Object Mode (tecla G, mover; R, rotar; S, Escalar, Shif + D,
duplicar; etc). Y están disponibles en la ventana de la izquierda (activar con tecla T), nombrada ahora como Mesh
Tools:

TIP: La tecla espaciadora activa la opción de “búsqueda” de comandos en Blender.

Extrude.

Otra herramienta que vamos a utilizar mucho es el comando Extrude, que como su nombre lo indica permite realizar
una extrusión al elemento que escojamos(vértice, arista, cara). Por ejemplo, para realizar extrusiones sucesivas a una
cara del cubo existente en la escena realizamos la siguiente operación:
Estando en Edit Mode debemos habilitar "modo selección de caras". A continuación seleccionamos una cara del cubo
pinchándola con el botón derecho del mouse y apretamos la tecla E (atajo del comando extrude). Podrás expandir la
extrusión moviendo el cursor hasta hacer click en un punto con el botón izquierdo del mouse.
Si repites la operación varias veces, obtendrás una figura parecida a la de la imagen siguiente:

Puedes intentar extrusiones a los vértices o las aristas simplemente cambiando el modo de selección a arista o
vértice.
El comando Extrude también puedes encontrarlo en la ventana de la derecha Mesh Tools o en el menú Mesh >
Extrude Individual / Extrude Region
Las opciones Region/Individual son para cuando seleccionamos más de un elemento a la vez para hacer una
extrusion. Por ejemplo, en el caso de seleccionar dos caras, si marcamos Extrude Region o Extrude Individual el
resultado de la extrusion para cada caso será como se muestra en la siguiente imagen:

TIP: Como en otros programas, si mantienes presionada la tecla Shift podrás seleccionar más de un elemento.

 

Bueno, dejaremos hasta acá la revisión de comandos de edición y pasaremos a modelar directamente. Lo que falte
por aprender lo veremos sobre la marcha.

MODELADO ARQUITECTONICO CON BLENDER

De la planta al modelo 3D

Partiremos modelando una serie de recintos, de la misma forma que se estila en otros programas 3D
tradicionales. Es decir, partiremos desde una planta del edificio en 2D ya dibujada previamente con algún programa
CAD, la que importaremos a Blender para usar como plantilla base.
Un cosa muy importante que hay que saber, es que a diferencia de otros programas 3D tipo CAD, en blender no
podemos dibujar directamente lineas, ni entidades ya definidas como muros (como en programas BIM como
Vectorworks). Blender trabaja con un grupo determinado de elementos 3D que son un conjunto de mallas (plane,
circle, cube, UV sphere, etc) y curvas (bezier, nurbs, etc). Y sus componentes (vértices, aristas, caras). Estos
elementos los encuentras en el Menú superior Add:

 

La idea es que a partir de modificar estos elementos insertados en la escena, se puedan crear otros nuevos con
formas más complejas y que se adapten al diseño que deseamos. En estricto rigor, cuando importamos nuestra
plantilla 2D, esta se convierte en un objeto, una malla con aristas y vértices que podemos editar.

Al comenzar y para que no nos estorbe, borramos previamente el cubo que aparece por defecto al iniciar Blender
(tecla Supr > Enter).

Nota: Si insertas objetos a una escena en Modo Objeto (Objet Mode) estos se comportan como mallas (mesh)
independientes. Pero si los insertas en Modo Edición (Edit Mode) los objetos pasan a ser parte de la misma malla que
esta siendo editada.

IMPORTANTE: El programa no tiene avisos de advertencia al momento de cerrar o iniciar un nuevo proyecto,
por lo que si no se han guardado previamente los cambios, estos se perderán.

Importando archivos DXF

El archivo CAD 2D del edificio que queremos importar debe estar en formato DXF. Como Blender 2.55 está en
desarrollo, no trae incorporado un módulo para importar archivos de este formato, por lo que necesitamos instalarlo
(dicha opción si viene instalada por defecto en cada versión de Blender hasta la 2.49).
El módulo lo puedes descargar desde esta dirección:
http://wiki.blender.org/index.php/Extensions:2.5/Py/Scripts/File_I-O/DXF...

Para instalar el script debes seguir las instrucciones de la página. Copia el archivo script dentro de la carpeta "addons"
en el directorio de Blender 2.55/scripts/addons (en mi caso).

Luego, para habilitar el script:
+ Menú File > User Preferences
+ Aparecerá una pequeña ventana con pestañas, selecciona pestaña Add-Ons.
+ De la lista marca la casilla en Import/Export: Import Autocad DXF (.dxf)
+ Has click en el botón Save As Default que está abajo en la ventana para guardar los cambios en la configuración
(de otro modo cuando cierres Blender el módulo se deshabilitará, aunque no es importante si ya no lo necesitas).
+ Para importar el archivo ve al menú File > Import > Autocad (.dxf)

+Seleccionas el archivo DXF en cuestión y listo.

Si todo ha salido bien, deberías ver las plantas y elevaciones del pabellón tal como se muestran en las imagenes de
la siguiente página.

Nota:
No hay que olvidar que este módulo para importar .dxf es reciente para Blender 2.55 por lo que no soporta bloques ni
texto del archivo CAD, sólo las linea. Si estos elementos son importantes, entonces te recomiendo romper los bloques
del archivo CAD (explode) antes de importarlo a Blender. En el caso de mi ejemplo, además tuve que convertir el
archivo original DWG a la versión DXF R1 2 (puedes usar un conversor gratuito para esto).
Otra opción es que instales la versión estable Blender 2.49 cuyo módulo viene preinstalado y soporta mucho mejor los
archivos DXF. Luego de importar el archivo DXF guardas el proyecto y lo abres posteriormente con Blender 2.55.

Planta, corte y alzados: Pabellón Alemán para la Exposición de Barcelona en 1 929, diseñado por Ludwig Mies Van
Der Rohe. Descárgalo desde acá: http://www.arquilove.com.ar/planos-cad/pabell-n-barcelona/pabellon-barce...

Vista en planta (tecla 7).

Trabajar con Escalas en Blender

Una típica pregunta sobre Blender es por la escala o la unidad de métrica en que se trabaja ¿metros, centímetros,
pulgadas? ¿1 :1 , 1 :50, 1 :1 00? Bueno, la respuesta es que Blender no trabaja en metros ni centímetros. Simplemente
trabaja en unidades basadas en las coordenadas cartesianas. Sólo fíjate en la grilla que se ve en la escena. Cada
cuadrado de la grilla es una unidad (X=1 , Y=1 , Z=0).
Trabajar con exactitud en las medidas no es necesario si lo que se está haciendo es una representación 3D de un
edificio ya diseñado, para usos como fotografía publicitaria o marketing. Es decir si sólo buscamos generar renders
con texturas hiperrealistas y cosas así, para que el cliente pueda visualizar con realismo el proyecto. Sin embargo, si
como arquitectos estamos en plena etapa de diseño del edificio y requerimos modelar en 3D como parte de dicho
proceso, es indispensable trabajar con exactitud y claridad en las medidas en el ambiente 3D, para así poder
posteriormente traspasar dicha información a los planos constructivos.
En todo este ejercicio utilizaremos una serie de herramientas propias de Blender para trabajar con precisión en las
medidas, tal como lo haríamos en un programa CAD.

Entonces, lo más práctico, para quienes trabajamos con medidas como nosotros los arquitectos, es que
consideremos el cuadriculado de la grilla como si tuviera un metro por lado.
Idealmente, nuestro archivo CAD deberá estar dibujado en metros (1 .00 es un metro). Así, las proporciones de la
planta al momento de importarla a Blender coincidirán con las de la grilla. Lo mejor es tenerlo ya escalado con nuestro
programa CAD, pero si vemos que en comparación a la grilla de la escena la planta aparece muy grande podemos
volver a escalar la planta con el comando Scale de Blender: tecla S > ingresa un número que indique la proporción de
ajuste de escala > Enter
En la siguiente fase te indicaré un TIP muy útil para saber las medidas respectivas de los elementos en escena y que
te ayudará a orientarte en muchas cosas además de los ajustes de escala.

Nota: Actualmente, en el ícono "Scene" del panel de la botonera a la derecha de la pantalla, está la opción "Units",
donde se puede cambiar la opción de medición de unidades entre None (ninguna), Metric (métrica), Imperial
(imperial):

Actual opción de cambio de unidades de medida en el ícono Scene > Units (unidades) > none, metric, imperial

Midiendo y Modelando con Precisión en Blender

Bien. Ya tenemos nuestra planta base para comenzar a modelar. Básicamente lo que haremos a continuación será ir
alzando los muros del pabellón y demás paramentos.

La planta del pabellón Barcelona que hemos importado ha quedado como un objeto malla. No tiene caras, pero si
tiene vértices y aristas (edges). Utilizando las herramientas de transformación y edición vamos a trabajar los vértices y
aristas de la plantilla para crear muros, losas, ventanas, suelos, etc. en nuestro proyecto.

Para poder trabajar con las aristas y vértices de esta malla, debemos pasar a "Edit Mode" y tener el "modo de
selección arista" habilitado. Con el botón derecho del mouse podremos seleccionar cada linea (arista) de la planta en
forma independiente (si se quiere seleccionar más de un elemento debemos usar la tecla Shift; para seleccionar o de-
seleccionar todos los elementos basta con la tecla A).

Ahora bien, tal vez tengas dudas con las medidas de algún elemento, necesites tomar alguna distancia o quieras
modelar muros con precisión. Como dije anteriormente, si nos encontramos en mitad del proceso de diseño de un
edificio, trabajar en 3D con precisión es muy importante, para traspasar posteriormente la información a los planos
que se usarán para construir. Blender no tiene una herramienta directa para medir, pero si podemos saber las
longitudes de las aristas (edges) de cualquier elemento seleccionado, marcando la casilla de la opción "Edges
Length", al final de la Ventana Transform (tecla N), bajo el título "numeric". Esta opción permite visualizar el largo de
cada linea que seleccionemos (siempre en Edit Mode). Así, podemos saber el largo o alto de un muro, seleccionando
simplemente las correspondientes aristas (esto funciona tanto en 2D como en 3D), tal como se ve en la siguiente
imagen:

Visualización de longitudes de las aristas (edges), habilitando la opción Edges Length (al costado derecho).

Por ejemplo, ahora podemos saber hasta que alto vamos a alzar los primeros muros de nuestro modelo, ya que la
plantilla del pabellón Barcelona que estamos usando incluye las elevaciones del edificio. Basta con seleccionar
cualquier linea de las vistas laterales del edificio, para que aparezca la distancia que corresponde a la altura de los
muros (en este caso son 3, es decir 3 metros es la altura de piso a cielo).
También sirve esto para chequear las proporciones o escalas de las mallas que importamos desde otras fuentes,
como comenté en el párrafo dedicado a la escala en Blender. Si tienes dudas con respecto a la plata del pabellón,
una vez importada desde el archivo DXF, con esta herramientas puedes comparar medidas de cualquier parte del
dibujo, midiéndolo anteriormente con un programa CAD.

Nota: Bajo el título numeric, también están las opciones Edges Angle y Faces Area. Si las marcas mostraran
información sobre ángulo de la arista y área de la cara seleccionada. Por otro lado, en una nota anterior se indica
revisar la opción Units del ícono Scene en la botonera, para cambio de unidad de medida.

Pero ¿y si necesitamos medir una distancia entre dos puntos y no hay ninguna arista? En ese caso, podemos crear
una arista entre ambos puntos (tanto si están en 2D o 3D). Para ello existen dos opciones:

a) No dibujarla directamente, sino que habilitando el "modo de selección" en vértices y a continuación, con el botón
derecho del mouse seleccionamos los 2 vértices cuya distancia queremos medir (no olvidar pulsar tecla Shift para
seleccionar más de un elemento). Luego presionamos la tecla F y una arista se creará entre ambos puntos (y a su
vez, si seleccionas dos aristas puedes crear un plano). Con la opción "Edges Length" habilitada, sabremos el largo de
dicho trazo (luego puedes borrar la arista o la dejas si lo deseas).

b) La segunda opción es dibujar la nueva arista utilizando el comando Extrude (tecla E) sobre un vértice seleccionado
previamente. Veras como una linea surge desde el vértice en cuestión, extendiéndose libremente en el otro extremo
con el movimiento del mouse (para fijar el movimiento a una coordenada: teclas X, Y, Z). Con un click del botón
izquierdo del mouse fijarás la posición final de la nueva arista y la opción "Edges Length" te dará la distancia. Ahora, si
deseas hacer coincidir con exactitud dicho final con algún vértice o arista debes tener habilitado previamente el
comando Snap. Este funciona muy similar a los programas CAD y hará de magneto para "pinchar" con exactitud el
destino de nuestra nueva arista sobre vértices, aristas, caras, o elementos. Esta opción se habilita haciendo click en el
ícono del magneto, abajo de la Ventana 3D:

Está claro que el comando Extrude sobre aristas o vértices, más la opción Snap habilitada, serán tremendamente
útiles para modelar con precisión (además de tomar medidas), tal como lo veremos a continuación.

Nota: adicionalmente a lo ya explicado, para lograr desplazamientos, giros o extrusiones con medidas exactas,
debemos simplemente ingresar la medida con el teclado numérico después de iniciar una orden. También podemos
apoyarnos con las teclas X,Y,Z para fijar los movimientos a determinada coordenada.

Alzando Muros

Partiremos modelando los principales muros del edificio. Como ya he dicho todo este proceso se hace en Modo
edición (Edit Mode).

La forma más fácil y rápida de alzar muros a partir de la plantilla 2D es utilizar el comando de extrusion en las lineas
que forman los contornos de los muros:
Seleccione las lineas que desea extruir y a continuación presione la tecla E (moviendo libremente el ratón podrá ver
como las extrusion genera los planos del muro). Fije la coordenada de extrusion presionando la tecla Z. Indique la
altura de la extrusion pulsando la tecla 3 del teclado numérico (tres metros). Finalmente presione la tecla Enter.

El proceso comienza y termina como se ve en las siguientes dos imágenes:

Otro modo de crear los muros es insertando un objeto 3D y editarlo. En este caso nos bastará con un plano. Atención,
que para este trabajo necesitamos tener habilitado el comando Snap (con opción vértice):
Desde el menú superior insertamos el nuevo objeto Add > Mesh > Plane (este aparece en la ubicación del cursor 3D
en la escena). Ajustamos sus medidas a las dimensiones del muro que vamos a crear (esto en sus propiedades que
podemos ver en la ventana del costado con la tecla N). En este caso, ajustamos las medidas de 2x2 a 0.1 x0.1 A
continuación movemos el plano (tecla G) hasta la posición sobre uno de los contornos de los muros que vamos a
crear, tal como se ve en la siguiente imagen (con el Snap activado podemos posicionarlo con exactitud).

Ya posicionado lo que hacemos es un Extrude (tecla E) sobre uno de los lados del plano y lo extendemos fijándolo a
las coordenadas X, Y. Con ayuda del Snap activado y en opción vértice, vamos trazando nuestro muro con exactitud
deteniéndonos en cada encuentro y volviendo a extruir. Así hasta completar un trazado como se ve en la siguiente
imagen:

 

Se ha creado un trazado constituido por una serie de caras sobre la plantilla de los muros del edificio. A continuación,
en modo selección face, seleccionamos las respectivas caras y aplicamos Extrude, fijando a la coordenada Z.
Ingresamos la altura pulsando la tecla numérica 3(m) y finalizamos pulzando la tecla Enter. El resultado debiera ser
algo así:

Este método es un poco más lento al principio, pero trae bastantes ventajas a posterior, cuando nos toque ir
agregando detalles a los muros. Cosa que veremos más adelante.

Por el momento, continúe alzando el resto de los muros principales (no son muchos) con cualquiera de los dos
procedimientos descritos, de manera que termine con un modelado del edificio similar a esta última imagen:

 

Completando los detalles

Cuando ya se tenga los muros alzados seguramente necesitaremos completar algunos detalles como dinteles,
antepechos, vanos, etc. Para esto vamos a utilizar el comando Duplicate (tecla Shift + D), la herramienta "Loop Cut
and Slide" (Ctrl + R) y el comando Extrude (tecla E), aunque siempre se pueden usar otras formulas. La herramienta
Loop Cut permite subdividir las caras de los muros, de manera de poder modelar formas más complejas. Aquí la
vamos a utilizar para completar un dintel sobre el vano de una puerta. Tanto el comando Duplicate como Loop Cut y
Extrude están en la ventana Mesh Tools de la izquierda (visible con la tecla T).

La altura del dintel la vamos a marcar con una arista del canto del muro, usando el comando duplicar:
Seleccionamos una arista inferior del canto del muro. Pulsamos tecla Shift + D (duplicate). Fijamos la coordenada de
movimiento de la arista al eje Z. Ingresamos con el teclado numérico una altura de 2.1 (con el signo "-" cambia el
sentido de desplazamiento). Terminamos pulsando la tecla Enter.

Si te fijas, acá el comando duplicar lo usamos como el tradicional comando offset (paralelas) de los programas CAD.

Cuando ya tenemos una marca de referencia, procedemos a subdividir el muro. Ojo, que para completar esta
operación necesitamos tener habilitado previamente el comando Snap:
Presionamos las teclas Ctrl + R. Al mover el cursor sobre el muro veras como aparecen unas lineas de corte amarillas
(vertical y horizontal), has click con el botón izquierdo del mouse cuando aparece la linea horizontal para así
seleccionar ese sentido de corte. Verás que ahora la linea amarilla se mueve solo en el eje Z del muro, haz click con
el botón izquierdo por segunda vez. La linea amarilla queda fija mostrando sus tres vectores de movimiento. Con el
cursor del mouse pincha y arrastra el vector Z para volver a mover la linea de corte hasta la marca a 2.1 m que
dejamos en el canto del muro (el comando Snap activado hará que coincidan exactamente).

El proceso es algo como lo que se ve en estas 2 imágenes:

 

Izquierda: Linea de corte horizontal (he activado la vista traslucida de objetos para que se distinga mejor).

Derecha: Planos de muros divididos (vista en face select mode).

Para verificar las medidas que estamos trabajando para las alturas, recuerda que podemos verlas con la opción Edge
Length habilitada y seleccionando la arista respectiva:

Si detectamos algún error deshacemos lo hecho presionado Ctrl + Z. Ahora, si todo está correcto, simplemente
haremos un extrude sobre la cara superior del canto del muro para crear el dintel:
Seleccionamos una cara. Pulsamos tecla E (Extrude). Proyectamos la extrusion hasta el canto del otro muro (con el
comando Snap habilitado para un calce exacto). Pulsar Enter.
Así tendremos ya nuestro dintel. El mismo principio se puede aplicar a antepechos:

Nota: Cuando se subdividen caras de un muro en varias regiones, ya sea para crear vanos de ventas, puertas, etc.,
hay que tratar que estas divisiones sean siempre en sentidos ortogonales. Se debe evitar que surjan divisiones en
sentido diagonal en las caras, es decir, planos triangulares; ya que esto hará mucho más complicado la edición
posterior de dichos objetos. Una cosa que debes saber, es que Blender soporta polígonos de 3 y 4 lados como
máximo. Un plano con 5 o más lados obliga al programa a crear subdivisiones con triángulos (aunque esto no tiene
efectos en los renders).
Existe sin embargo, una rama de desarrollo paralelo de Blender, con una versión que soporta caras con más de 4
lados (opción ngons). El proyecto se llama BMesh y se espera que se integre pronto al tronco principal de Blender. Su
blog es http://bmeshblender.wordpress.com/ y puedes descargar sus versiones para todas las plataformas desde
http://www.graphicall.org/

La idea es que utilizando principalmente el comando Extrude sobre las marcas de la plantilla, se continué modelando
los diferentes paramentos internos del pabellón como son las mamparas, pilares y las puertas. En este caso yo he
modelado también los cristales de las mamparas:

La transparencia de las mamparas se logra seleccionando el plano de la ventana y posteriormente pulsando en la
ventana de botonera (lado derecho de la pantalla) el ícono materiales. Las ventanas deben tener su propio material
asignado ya que cuando los planos se crean en modo edición adoptan los materiales del conjunto de la malla.

Botonera: círculo naranja=materiales/ cubo naranja= objeto.

Para la transparencia de los cristales hay que marcar la opción Transparency con un factor Alpha de 0.5.
Luego se pulsa el ícono Object en la misma botonera y se marca la opción Transparency que está bajo el título
Display.

Faltaría por explicar otros muchos métodos para construir muros curvos o con aberturas, etc. Pero no podemos verlas
en esta guía por que si no nos extenderíamos demasiado. Tal vez, más adelante pueda agregar dicha información
como un anexo. Por lo pronto te sugiero consultes los links con tutoriales que están al final de esta guía.

Layers.

Como una forma de organizar nuestra escena y los modelos que en ella están, podemos distribuir los objetos 3D de
nuestra escena en diferentes layers. Esto es muy útil si, por ejemplo, necesitamos "apagar" cualquier objeto para que
no nos estorbe mientras modelamos otros. A su vez, podemos discriminar cuales aparecerán en la imagen
renderizada y cuales no.
Los layers podemos encontrarlos en la barra de íconos bajo la Ventana 3D (Object Mode):

Así, para nuestro modelo del pabellón Barcelona, podemos tener la planta separada como un objeto en un layer, los
muros en otro layer y la cubierta en un tercer layer.
Eso si, los layers actúan sobre objetos o mallas independientes:
En Modo Objeto selecciona el objeto 3D a trasladar. A continuación, pulsando la tecla M aparece sobre la pantalla las
20 casillas de layers. Al hacer click sobre alguna de las casillas verás que el objeto seleccionado desaparece (es
trasladado al respectivo layer). Para ver los objetos de diferentes layers en la ventana 3D, simplemente se pulsa en la
casilla ocupada con una marca. Para ver los objetos juntos, se presiona además simultáneamente la tecla Shift.

Nota: para separar una malla en varios objetos independientes, se selecciona la parte de la malla que se desea
separar (caras, vértices o aristas) y se pulsa la tecla P. Se puede escoger entre separar selección, material, loos part
(todo esto en Modo Edición).
Para unir diferentes objetos en una sola malla, se seleccionan los objetos 3D (en Modo Objeto) y se pulsa Ctrl+J. Las
diferentes mallas pasan a ser una sola y a ocupar el mismo layer.

Modelando las Cubiertas

Para modelar las losas de la cubierta del pabellón, podemos optar por agregar a la escena un plano desde el menú
Add > Mesh > Plane, al que modificaremos sus dimensiones (tecla N para ver las propiedades). O podemos optar por
seleccionar dos líneas o aristas de la proyección de la cubierta en la plantilla, como se ve en la siguiente imagen
(deben tener el mismo largo):

Teniendo ambas aristas seleccionadas, pulsamos la tecla F lo que creará un plano, tal como se ve a continuación.
Recordar: Si se seleccionan vértices, con la tecla F se crean aristas. Si se seleccionan aristas, se crearán planos.

El siguiente paso es seleccionar el plano recién creado y desplazarlo hasta su posición sobre la altura de los muros
con la tecla G. Luego pulsamos la tecla Z para fijar el sentido de desplazamiento e ingresamos la altura 3m con el
teclado numérico. Finalmente presionamos Enter.
Una vez ubicado, procedemos a hacer una extrusion (tecla E) sobre el plano para transformarlo en una losa de 30cm
de espesor.

En algunas fotografías del pabellón se puede ver que el techo posee una cubierta impermeable con un pequeño borde que sobresale de la losa. Esta forma se puede modelar de la siguiente manera:

Seleccionamos el plano superior de la losa. Le hacemos una extrusion (tecla E) pero sin desplazamiento, para esto
podemos usar la opción Snap sobre uno de los vértices de la losa. La extrusion creará un nuevo plano que queda
sobre el plano original. Seleccionamos un lado del plano y pulsando la tecla Shift+D creamos un duplicado de la arista
para desplazarla en una determinada medida hacia un costado (como el comando offset de los programas CAD). Esta
arista será nuestra marca. Ahora seleccionamos el nuevo plano superior y lo escalamos presionando la tecla S. Los
bordes del plano se ampliarán en una proporción de escala que la fijamos con exactitud moviendo el cursor hacia la
arista de referencia con la opción Snap habilitada. Presionando el botón izquierdo del mouse completamos la
operación. De esta forma logramos darle un contorno a la losa que podemos extruir y darle un espesor. Tal como se
ve en la imágen. Es necesario este procedimiento pues si intentamos escalar el plano superior de la losa
directamente, se deforman los cantos.

Cuando ya tengamos listas las losas de las cubiertas, será recomendable convertirlas en objetos independientes y
llevarlas a otro layer para que no estorben si necesitamos seguir trabajando sobre los muros e interiores del modelo,
siguiendo el procedimiento que expliqué en el tema anterior.

Nota: si deseamos ir más allá con los detalles, podemos modelar las suaves pendientes de la cubierta. Simplemente
selecciona los cuatro vértices del plano superior de la cubierta y escala pulsando tecla S. La proporción de escala
será cero, por lo que ingresa el número con el teclado numérico y posteriormente presiona Enter. La cara del plano se
dividirá en cuatro triángulos. Selecciona el vértice del centro y muévalo en el sentido del eje Z para generar las
pendientes.

TIP: En el menú File > User Preferences > pestaña Interface, puedes marcar la opción Rotate Around Selection. Esto permite mover la visión de la Ventana 3D en torno al modelo con más comodidad. Con el botón Save As Default que está abajo en la ventana se guardan los cambios en la configuración. Pero ojo, que si está abierto un archivo, Save As Default lo establece como la escena nueva por defecto.

Modelando Suelos

Para modelar los suelos agregamos desde el menú de objetos (Add > Mesh > Plane) algunos planos que ubicamos
con exactitud en las esquinas de los recintos. A continuación ajustamos las dimensiones de estos planos arrastrando
con el cursos alguno de sus lados hasta cubrir un área completa (ayudándonos con la opción Snap habilitada). Tal
como se observa en las dos siguientes imágenes:

Agregando un nuevo objeto 3D (plano-malla) como suelo. (Add > Mesh > Plane)

Se ajusta las dimensiones del plano-malla a un área determinada arrastrando uno de sus lados (seleccionar una
arista y pinchar + arrastrar con los vectores de color).

Para completar todo el suelo del pabellón, debemos usar varios planos-mallas, pues recordemos que Blender no
soporta caras de más de 4 lados. Cuidaremos además de dejar un plano completo con las dimensiones exactas,
sobre cada una de las dos piletas que tiene el pabellón:

Para modelar la profundidad las piletas, seleccionamos el respectivo plano y ejecutamos Extrude, fijando el
desplazamiento al eje Z e ingresando la medida respectiva (50cm):

El resultado debe verse como algo así:

Seleccionar plano > Tecla E > Tecla Z > ingresa 0.5 > Tecla Enter.

La escalinata puede ser modelada de varias formas. Yo simplemente realicé una serie de extrusiones a las aristas de
la plantilla para generar dos planos como "una huella y contra huella". Luego por medio del comando Duplicar (tecla
Shift+D) y Trasladar (tecla G) copié y ubiqué los peldaños hasta completar la escalinata. tal como se ve en las dos
siguientes imágenes (con la opción Snap habilitada):

Extrude (tecla E) sobre dos aristas para generar una huella y contrahuella.

El resto de la escalinata se arma copiando y ubicando cada peldaño.

Para modelar el zócalo del pabellón, vamos seleccionando cada vértice de cada esquina del suelo del pabellón y le
aplicamos el comando Extrude, para generar una arista en el sentido del eje Z. A cada arista le damos un largo
determinado, según podemos recoger de las medidas de las respectivas elevaciones del pabellón que están en la
misma plantilla. A continuación, seleccionamos dos aristas de cada lado del pabellón y pulsamos la tecla F, para
generar un plano que será el zócalo del pabellón:

Para generar las esquinas del zócalo: Seleccionar vértice > Tecla E > Tecla Z > ingresa medida > Tecla Enter.
Para completar las caras el zócalo: Seleccionar aristas > Tecla F.

Una vez completado todo el perímetro del zócalo del pabellón, debieras tener una imagen como esta:

Con esto podemos considerar casi terminado nuestro modelo del pabellón alemán de Mies Van Der Rohe. Puedes ir
completando con más detalles el modelo si deseas. Por ejemplo, yo le agregué algunas sillas Barcelona que encontré
en un repositorio de Google:
http://sketchup.google.com/3dwarehouse/search?q=silla+bacerlona&styp=m&btnG=Buscar
Pero aún falta un último paso en esta guía: modelar un terreno de entorno.

Modelando el Entorno

Con la esperanza de que a estas alturas de la guía no hayas abandonado, lo que vamos a realizar ahora es crear un
terreno o entorno donde esté asentado el modelo.
Para modelar un suelo de entorno para el modelo de nuestro pabellón, añadimos a la escena, desde el menú Add, un
plano y lo escalamos lo suficientemente grande para rodear todo el modelo, tal como se ve en la imagen:

La idea es que este plano sea un objeto-malla independiente. Preferentemente lo podemos ubicar en un layer a parte
para poder trabajar cómodamente en él (seleccionar objeto > tecla M > asignar layer). En seguida, teniendo
seleccionado el plano, hacemos click en el botón Subdivide que está en la ventana Mesh Tools (tecla T). Esto hará
que el plano se subdivida a la vez en varios planos. Con cada click que hacemos sobre el botón subdivide, el número
de subdivisiones aumenta.

Una vez que hemos subdividido nuestro plano, para darle un relieve topográfico seleccionamos algunas caras y las
desplazamos (tecla G) en el sentido del eje Z (yo he borrado algunas caras para que no aparezcan dentro del modelo
del pabellón). Nos podemos ayudar con las diferentes alturas de los lados del zócalo para ir modelando la topografía,
de forma que coincida con el borde inferior de cada lado del zócalo del pabellón.

Nuestro terreno está casi listo, pero se ve muy facetado. Vamos a darle una forma más suave a la superficie:

Teniendo seleccionado nuestro terreno, pinchamos en la tecla Smooth que está bajo el título Shading en la ventana
Object/Mesh Tools (tecla T). Este comando lo que hace es suavizar las aristas de las caras dándole a las superficies
de una malla una apariencia algo más “orgánica”:

Y con esto ya está nuestro modelo terminado. Activando todos los layers (muros, cubierta, etc) podemos ver el
conjunto:

Esta guía para aprender a modelar arquitectura en Blender no incluye el proceso de asignación de materiales ni
renderizado, ya que aún no me manejo con ello. Pero tú puedes aprender más con los diferentes tutoriales que hay
disponible en la red. Yo he incluido unos pocos al final de este post.
En todo caso, he agregado algunos renders muy básicos aplicando la opción Ambient Occlusion (propiedades de
escena en ventana de la botonera), que crea una luz de ambiente homogénea a la escena. Presionando las teclas
Crtl + Alt + 0 ubicas rápidamente la cámara en el mismo ángulo de visión de la Ventana 3D. Luego presionando la
tecla F1 2 obtendrás un render de la toma que aparecerá en la ventana 3D. Para guardar la imagen ve al menú Image
que está bajo la ventana y selecciona Save. Para salir de la visualización del render pulsa tecla Esc.

Nota: esas sombras negras que se observan en algunos bordes del modelo en los renders son producto de una superposición de caras o planos. Para evitarlo simplemente borra las caras extras y cuida de no superponer cuando modelas.

*******************************************************************************************************************

NOTAS COMPLEMENTARIAS

Nota 1: Esta guía esá basada en el tutorial "Breve guía para modelar arquitectura en Blender 2.55b" de Rafael Moya Castro, licencia CC BY-NC (tutorial disponible para descarga en ForoARQ-SL) .

Nota 2: Esta guía se complementa con el tutorial EXPORTANDO VISTAS 2D DESDE BLENDER A FORMATO CAD 

Nota 3: La guía original fue elaborada a partir de diversas fuentes disponibles en la Internet. A continuación se citan algunas de ellas:

MODELLING ARCHITECTURE WITH PRECISION IN BLENDER

http://yorik.uncreated.net/tutorials/precisionmodelling-blender.html

Quick guide to model walls in Blender 3d for architectural visualization

http://www.blender3darchitect.com/2009/1 1 /quick-guide-to-model-walls-in-blender-3d-for-architectural-visualization/

Guía de iniciación a Blender 2.5

https://docs.google.com/View?id=dhs3vfzq_2046g2hd92g2

Intro a Blender 2.5 (video)

http://vimeo.com/77871 98

Fuente de los planos utilizados:

Pabellón Alemán para la Exposición de Barcelona en 1 929, diseñado por Ludwig Mies Van Der Rohe.
http://www.arquilove.com.ar/planos-cad/pabell-n-barcelona/pabellon-barcelona-001

Grupos:

Comentarios

LGM

Muy buen tuto, la técnica de

Muy buen tuto, la técnica de duplicar una arista cual offset para usarla como referencia me acaba de evitar muchos dolores de cabeza, se agradece, era sencillo pero la verdad no se me ocurrió.

Lo mismo lo de P para separar y CTRL + J para juntar mallas, lo aprendí después de leer muuucho y para el uso que le da un arquitecto son funciones muy importantes.

creo que supiste sintetizar aquellos aspectos del modelado ''con presición'' que más inquietan al arquitecto iniciado en BLENDER, el tutorial de Yorik al respecto es muy recomendable así como su blog en general.

Por otro lado hago un aporte que encontré hace poco y me sirvió bastante para aclarar muchas ideas:

http://www.blenderguru.com/the-complete-architecture-series/

y recomiendo un libro que el autor de este tutorial recomienda en el video pero tal vez no se le entiende porque habla un inglés muy cerrado, parece irlandés o algo así, es un libro sobre criterios para iluminar y mapear correctamente una escena, son criterios genéricos aplicables a cualquier programa 3D.

Se llama DIGITAL LIGHTING AND RENDERING, yo lo lonseguí en inglés.

 

bitacovir

Gracias LGM por el

Gracias LGM por el comentario. La verdad es que pense en una forma de abordar las tecnicas mas basicas para trabajar que le fueran utiles a un arquitecto durante el proceso de modelado. Blender ofrece multiples opciones que ayudan a hacer mas facil el trabajo a medida que te manejas con el. Pero lo principal es entender que siempre puedes encontrar un metodo para resolver un proceso de modelado. Uno esta acostumbrado a buscar herramientas directas como offset, draw, cut, extend, etc. Y a veces no te das cuenta que puedes hacer las mismas operaciones con copy, move y extrude (no olvidemos que esta simplicidad ayuda a que el programa no sea tan pesado como otros muchos modeladores). Mucho de esta desorientacion se debe a que se buscan respuestas entre quienes no entienden el trabajo de un arquitecto y creen que todo se trata de modelar para infografia hiperrealista, por lo que dejan de lado la presicion, medidas, etc. Eso es posible en esa area de trabajo,  pero la etapa de diseno donde se ha de generar informacion para planos constructivos es previa a las fotos y los render y requiere de datos cuantificables, pero como se ve en esta guia, es perfectamente realizable con todo su rigor por Blender en su formato mas sencillo. Ahora, si quieres puedes ir investigando cada vez mas y te encontraras con opciones adicionales como http://bmeshblender.wordpress.com/ donde se facilita la realizacion de planos con multiples lados.

Carlos

Una pregunta, Rafael: tengo

Una pregunta, Rafael: tengo claro como extruir muros a partir de planos, pero ¿qué ocurre con elementos que tengan curvas como el propio pilar del pabellón? ¿Cómo podría modelarlas con Blender?

bitacovir

Si, las curvas...Ese fue un

Si, las curvas...

Ese fue un capitulo que tenia pensado trabajar mas adelante y que nunca lo aborde.

Para las curvas se pueden insertar elementos llamados curvas bezier y nurbs curve.

Ve a la barra superior, al menú Add y alli se encuentran. Aparecen en la posición del cursor 3D por lo que debes ubicarlas luego donde las quieres. Pero este método es muy engorroso y lento. Existen otros que permiten redondear esquinas automáticamente y que se trabajan creo con la herramienta ¨´bevel´. Pero yo no se como usarla así que te recomiendo que consultes en algún foro de usuarios de blender (la guía cita algunos) o pregunta directamente a Yorik.

 

¿Probaste a dibujar el perfil con CAD e importarlo a blender?

¿que te sale en las curvas? Es probable que te salga una curva de puntos... esas se podrian convertir en una curva tipo bezier y extruirla...

bitacovir

Acá una rutina básica sobre

Acá una rutina básica sobre las curvas. Que en realidad es de circulos.

1.- tecla numpad 7 para ver en planta.

2.- ubica el cursor 3D sobre la grilla o sobre un punto seleccionado para recibir el centro del circulo: Shift + S

3.- Agrega un circulo: menú Add> mesh> circle.

4.- en Edit Mode veras que el circulo que aparece esta compuesto de un sin numero de tramos rectos. Puedes escalar el circulo (tecla E) hasta algún punto de referencia usando el snap habilitado. Ese punto de referencia lo puedes crear duplicando cualquier elemento existente (punto o línea) y desplazándolo (Shift + D, fijando coordenada con Y o X).

5.- Borra los vértices del circulo que están de mas, de forma que dejas solo el tramo de curva que te interesa.

Nota para un dibujo como el que se ve en la imagen lo mas conveniente es dibujar un segmento del elemento y luego hacer mirrows:

A) Seleccionar elemento

B) Shift+D

C)tecla S y luego tecla X

D) tipear -1

E) Enter.

Finalmente se ubica el duplicado seleccionándolo y moviéndolo con la tecla G